Back to overview
My2Cloud Portal and My2Cloud API are down
Feb 03 at 04:38pm GMT
Affected services
My2Cloud API
Resolved
Feb 04 at 10:32am GMT
New certificate has been applied
Affected services
Created
Feb 03 at 04:38pm GMT
We are still awaiting the new SSL cert. People can still use the portal, you will just get the warning upon visitation to the site. Once the Certs are received we will update them promptly.
Affected services