Partial backup2cloud outage
Incident Report for Assurestor
Resolved
Everything has been updated and the platform is operational again.
Posted Sep 13, 2022 - 12:01 BST
Investigating
We are currently investigating this issue.
Posted Sep 13, 2022 - 10:31 BST
This incident affected: Backup2Cloud (Backup2Cloud UK).